using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9'\.,\s\-&()]{2,20}$";
string substitution = @"";
string input = @"1234AqwdaDS1234567.5";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}