const regex = /^[a-zA-Z0-9'\.,\s\-&()]{2,20}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9\'\\.,\\s\\-&()]{2,20}$', '')
const str = `1234AqwdaDS1234567.5`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);