$re = '/^[a-zA-Z0-9\'\.,\s\-&()]{2,20}$/';
$str = '1234AqwdaDS1234567.5';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;