// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[a-zA-Z0-9'\.,\s\-&()]{2,20}$").unwrap();
let string = "1234AqwdaDS1234567.5";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}