use strict;
my $str = '1234AqwdaDS1234567.5';
my $regex = qr/^[a-zA-Z0-9'\.,\s\-&()]{2,20}$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";