re = /^[a-zA-Z0-9'\.,\s\-&()]{2,20}$/
str = '1234AqwdaDS1234567.5'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result