# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?!=).)*$//;t' <<< "abcj hsd723=198 2912
abcjhsd7231982912 13123
1212
"