#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^((?!=).)*$"
Local $sString = "abcj hsd723=198 2912" & @CRLF & _
"abcjhsd7231982912 13123" & @CRLF & _
"1212" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)