re = /^((?!=).)*$/
str = 'abcj hsd723=198 2912
abcjhsd7231982912 13123
1212
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result