using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!=).)*$";
string substitution = @"";
string input = @"abcj hsd723=198 2912
abcjhsd7231982912 13123
1212
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}