const regex = /^((?!=).)*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!=).)*$', '')
const str = `abcj hsd723=198 2912
abcjhsd7231982912 13123
1212
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);