#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-z\dâ„¢][a-z\d\sâ„¢]{1,24}(?<!\s)$"
Local $sString = "AdriaN" & @CRLF & _
"$tackoverFlow" & @CRLF & _
" StackoverF" & @CRLF & _
"StackoverFl0w" & @CRLF & _
"â„¢ Stack Over Flow â„¢" & @CRLF & _
"StækOverFlow"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")