$re = '/(?im)^[a-z\dâ„¢][a-z\d\sâ„¢]{1,24}(?<!\s)$/';
$str = 'AdriaN
$tackoverFlow
StackoverF
StackoverFl0w
â„¢ Stack Over Flow â„¢
StækOverFlow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);