import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?im)^[a-z\\dâ„¢][a-z\\d\\sâ„¢]{1,24}(?<!\\s)$";
final String string = "AdriaN\n"
+ "$tackoverFlow\n"
+ " StackoverF\n"
+ "StackoverFl0w\n"
+ "â„¢ Stack Over Flow â„¢\n"
+ "StækOverFlow";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}