re = /(?im)^[a-z\dâ„¢][a-z\d\sâ„¢]{1,24}(?<!\s)$/
str = 'AdriaN
$tackoverFlow
StackoverF
StackoverFl0w
â„¢ Stack Over Flow â„¢
StækOverFlow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end