import re
regex = re.compile(r"(?im)^[a-z\dâ„¢][a-z\d\sâ„¢]{1,24}(?<!\s)$")
test_str = ("AdriaN\n"
"$tackoverFlow\n"
" StackoverF\n"
"StackoverFl0w\n"
"â„¢ Stack Over Flow â„¢\n"
"StækOverFlow")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")