# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\.)([^\W\d\_])/\U$1/gm;t' <<< "Run-D.m.C.
Run-D.M.c.
Run-D.m.c.
Run-d.m.c.
R.E.M.
r.E.M.
R.e.M.
R.e.m.
r.e.m."