const regex = /(?<=\.)([^\W\d\_])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.)([^\\W\\d\\_])', 'gm')
const str = `Run-D.m.C.
Run-D.M.c.
Run-D.m.c.
Run-d.m.c.
R.E.M.
r.E.M.
R.e.M.
R.e.m.
r.e.m.`;
const subst = `\U$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);