import Foundation
let pattern = #"(?<=\.)([^\W\d\_])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Run-D.m.C.
Run-D.M.c.
Run-D.m.c.
Run-d.m.c.
R.E.M.
r.E.M.
R.e.M.
R.e.m.
r.e.m.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)