#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\.)([^\W\d\_])"
Local $sString = "Run-D.m.C." & @CRLF & _
"Run-D.M.c." & @CRLF & _
"Run-D.m.c." & @CRLF & _
"Run-d.m.c." & @CRLF & _
"" & @CRLF & _
"R.E.M." & @CRLF & _
"r.E.M." & @CRLF & _
"R.e.M." & @CRLF & _
"R.e.m." & @CRLF & _
"r.e.m."
Local $sSubst = "\U$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)