using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.)([^\W\d\_])";
string substitution = @"\U$1";
string input = @"Run-D.m.C.
Run-D.M.c.
Run-D.m.c.
Run-d.m.c.
R.E.M.
r.E.M.
R.e.M.
R.e.m.
r.e.m.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}