import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\.)([^\\W\\d\\_])";
final String string = "Run-D.m.C.\n"
+ "Run-D.M.c.\n"
+ "Run-D.m.c.\n"
+ "Run-d.m.c.\n\n"
+ "R.E.M.\n"
+ "r.E.M.\n"
+ "R.e.M.\n"
+ "R.e.m.\n"
+ "r.e.m.";
final String subst = "\\U$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}