#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td abbr=[“"]fileOne["â€]>(.*?)<\/td>"
Local $sString = "<html>" & @CRLF & _
"<head>" & @CRLF & _
"</head>" & @CRLF & _
"<body style="width: 50%; height: 50%;">" & @CRLF & _
"<div style="top: 10%; left: 10%; position: absolute;">" & @CRLF & _
"<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">" & @CRLF & _
"<table style="width:300px">" & @CRLF & _
"<tr>" & @CRLF & _
"<td abbr="fileOne"><a href=“someFile†id="text">Install file one here…</a></td>" & @CRLF & _
"<td abbr="fileTwo"><a href=“someFileTwo†id="text">install file Two here…</a></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
"</div>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
"</head>" & @CRLF & _
"<body style="width: 50%; height: 50%;">" & @CRLF & _
"<div style="top: 10%; left: 10%; position: absolute;">" & @CRLF & _
"<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">" & @CRLF & _
"<table style="width:300px">" & @CRLF & _
"<tr>" & @CRLF & _
"<td abbr=“fileOneâ€><a href=“someFile†id="text">Install file one here…</a></td>" & @CRLF & _
"<td abbr=“fileTwoâ€><a href=“someFileTwo†id="text">install file Two here…</a></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
"</div>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")