import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td abbr=[“\"]fileOne[\"â€]>(.*?)<\\/td>";
final String string = "<html>\n"
+ "<head>\n"
+ "</head>\n"
+ "<body style=\"width: 50%; height: 50%;\">\n"
+ "<div style=\"top: 10%; left: 10%; position: absolute;\">\n"
+ "<img border=\"0\" src=“icon.png†alt=\"Hello World\" width=\"120\" height=\"120\">\n"
+ "<table style=\"width:300px\">\n"
+ "<tr>\n"
+ "<td abbr=\"fileOne\"><a href=“someFile†id=\"text\">Install file one here…</a></td>\n"
+ "<td abbr=\"fileTwo\"><a href=“someFileTwo†id=\"text\">install file Two here…</a></td>\n"
+ "<td></td>\n"
+ "</tr>\n"
+ "</table>\n"
+ "</div>\n"
+ "</body>\n"
+ "</html>\n\n"
+ "<html>\n"
+ "<head>\n"
+ "</head>\n"
+ "<body style=\"width: 50%; height: 50%;\">\n"
+ "<div style=\"top: 10%; left: 10%; position: absolute;\">\n"
+ "<img border=\"0\" src=“icon.png†alt=\"Hello World\" width=\"120\" height=\"120\">\n"
+ "<table style=\"width:300px\">\n"
+ "<tr>\n"
+ "<td abbr=“fileOneâ€><a href=“someFile†id=\"text\">Install file one here…</a></td>\n"
+ "<td abbr=“fileTwoâ€><a href=“someFileTwo†id=\"text\">install file Two here…</a></td>\n"
+ "<td></td>\n"
+ "</tr>\n"
+ "</table>\n"
+ "</div>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}