const regex = /<td abbr=[“"]fileOne["â€]>(.*?)<\/td>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td abbr=[“"]fileOne["â€]>(.*?)<\\\/td>', 'g')
const str = `<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr="fileOne"><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr="fileTwo"><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>
<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr=“fileOneâ€><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr=“fileTwoâ€><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}