use strict;
my $str = '<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr="fileOne"><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr="fileTwo"><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>
<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr=“fileOneâ€><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr=“fileTwoâ€><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>';
my $regex = qr/<td abbr=[“"]fileOne["â€]>(.*?)<\/td>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}