import Foundation
let pattern = #"<td abbr=[“"]fileOne["â€]>(.*?)<\/td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr="fileOne"><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr="fileTwo"><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>
<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr=“fileOneâ€><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr=“fileTwoâ€><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)