using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td abbr=[“""]fileOne[""â€]>(.*?)<\/td>";
string input = @"<html>
<head>
</head>
<body style=""width: 50%; height: 50%;"">
<div style=""top: 10%; left: 10%; position: absolute;"">
<img border=""0"" src=“icon.png†alt=""Hello World"" width=""120"" height=""120"">
<table style=""width:300px"">
<tr>
<td abbr=""fileOne""><a href=“someFile†id=""text"">Install file one here…</a></td>
<td abbr=""fileTwo""><a href=“someFileTwo†id=""text"">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>
<html>
<head>
</head>
<body style=""width: 50%; height: 50%;"">
<div style=""top: 10%; left: 10%; position: absolute;"">
<img border=""0"" src=“icon.png†alt=""Hello World"" width=""120"" height=""120"">
<table style=""width:300px"">
<tr>
<td abbr=“fileOneâ€><a href=“someFile†id=""text"">Install file one here…</a></td>
<td abbr=“fileTwoâ€><a href=“someFileTwo†id=""text"">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}