$re = '/<td abbr=[“"]fileOne["â€]>(.*?)<\/td>/';
$str = '<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr="fileOne"><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr="fileTwo"><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>
<html>
<head>
</head>
<body style="width: 50%; height: 50%;">
<div style="top: 10%; left: 10%; position: absolute;">
<img border="0" src=“icon.png†alt="Hello World" width="120" height="120">
<table style="width:300px">
<tr>
<td abbr=“fileOneâ€><a href=“someFile†id="text">Install file one here…</a></td>
<td abbr=“fileTwoâ€><a href=“someFileTwo†id="text">install file Two here…</a></td>
<td></td>
</tr>
</table>
</div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);