#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^>\n]*>){0,3}[^>\n]*"
Local $sString = "afsad>adfsaf>asfasf>afasdX>asdffs>asfdf>" & @CRLF & _
"23433>433453>4>4559>455>3433>" & @CRLF & _
"adfd>adafs>afadsf>" & @CRLF & _
"test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")