using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^>\n]*>){0,3}[^>\n]*";
string input = @"afsad>adfsaf>asfasf>afasdX>asdffs>asfdf>
23433>433453>4>4559>455>3433>
adfd>adafs>afadsf>
test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}