import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^>\\n]*>){0,3}[^>\\n]*";
final String string = "afsad>adfsaf>asfasf>afasdX>asdffs>asfdf>\n"
+ "23433>433453>4>4559>455>3433>\n"
+ "adfd>adafs>afadsf>\n"
+ "test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}