re = /^(?:[^>\n]*>){0,3}[^>\n]*/m
str = 'afsad>adfsaf>asfasf>afasdX>asdffs>asfdf>
23433>433453>4>4559>455>3433>
adfd>adafs>afadsf>
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end