#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "/\*.*?\*/"
Local $sString = "/*Kommentar*/select * from xyz;/*Noch mehr Kommentar*/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)