const regex = new RegExp('/\\*.*?\\*/', 'g')
const str = `/*Kommentar*/select * from xyz;/*Noch mehr Kommentar*/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);