$re = '//\*.*?\*//';
$str = '/*Kommentar*/select * from xyz;/*Noch mehr Kommentar*/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;