use strict;
my $str = '/*Kommentar*/select * from xyz;/*Noch mehr Kommentar*/';
my $regex = qr//\*.*?\*//p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";