using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:[^,()]*|(?:\([^)]*\)))*$).*$";
string input = @"foobar
foo,bar
foo(xx,yy)bar
foo(xx,yy),baz
foo,(xx,yy)qux
a,b,c,d{
a,b(c, d),e {
a,(b,c),d{
a , bwefbfrew{
a,:is(b,c)s ss:is(b,c)sssss{
wefewfew,fewf{
fwafaewa,(b,c){
wefwefewfee{
(a,b,c,d)eeeeee(few)eeee{
ewfeweew{
wafewaf(s)ewfewew(){
afewfe(s,)wfew{
fef ewee{
a sefe few:has(few,few){
aafew:has(few,fewf,few){
span:is(p, b, a),da{
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}