import Foundation
let pattern = #"^(?!(?:[^,()]*|(?:\([^)]*\)))*$).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foobar
foo,bar
foo(xx,yy)bar
foo(xx,yy),baz
foo,(xx,yy)qux
a,b,c,d{
a,b(c, d),e {
a,(b,c),d{
a , bwefbfrew{
a,:is(b,c)s ss:is(b,c)sssss{
wefewfew,fewf{
fwafaewa,(b,c){
wefwefewfee{
(a,b,c,d)eeeeee(few)eeee{
ewfeweew{
wafewaf(s)ewfewew(){
afewfe(s,)wfew{
fef ewee{
a sefe few:has(few,few){
aafew:has(few,fewf,few){
span:is(p, b, a),da{
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)