const regex = /^(?!(?:[^,()]*|(?:\([^)]*\)))*$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:[^,()]*|(?:\\([^)]*\\)))*$).*$', 'gm')
const str = `foobar
foo,bar
foo(xx,yy)bar
foo(xx,yy),baz
foo,(xx,yy)qux
a,b,c,d{
a,b(c, d),e {
a,(b,c),d{
a , bwefbfrew{
a,:is(b,c)s ss:is(b,c)sssss{
wefewfew,fewf{
fwafaewa,(b,c){
wefwefewfee{
(a,b,c,d)eeeeee(few)eeee{
ewfeweew{
wafewaf(s)ewfewew(){
afewfe(s,)wfew{
fef ewee{
a sefe few:has(few,few){
aafew:has(few,fewf,few){
span:is(p, b, a),da{
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}