import re
regex = re.compile(r"^(?!(?:[^,()]*|(?:\([^)]*\)))*$).*$", flags=re.MULTILINE)
test_str = ("foobar\n"
"foo,bar\n"
"foo(xx,yy)bar\n"
"foo(xx,yy),baz\n"
"foo,(xx,yy)qux\n\n"
"a,b,c,d{\n"
" a,b(c, d),e { \n"
"a,(b,c),d{\n"
"a , bwefbfrew{\n"
"a,:is(b,c)s ss:is(b,c)sssss{\n"
"wefewfew,fewf{\n"
"fwafaewa,(b,c){\n\n"
"wefwefewfee{\n"
"(a,b,c,d)eeeeee(few)eeee{\n"
"ewfeweew{\n"
"wafewaf(s)ewfewew(){\n"
"afewfe(s,)wfew{\n"
"fef ewee{\n"
"a sefe few:has(few,few){\n"
"aafew:has(few,fewf,few){\n\n"
"span:is(p, b, a),da{\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")