re = /^(?!(?:[^,()]*|(?:\([^)]*\)))*$).*$/m
str = 'foobar
foo,bar
foo(xx,yy)bar
foo(xx,yy),baz
foo,(xx,yy)qux
a,b,c,d{
a,b(c, d),e {
a,(b,c),d{
a , bwefbfrew{
a,:is(b,c)s ss:is(b,c)sssss{
wefewfew,fewf{
fwafaewa,(b,c){
wefwefewfee{
(a,b,c,d)eeeeee(few)eeee{
ewfeweew{
wafewaf(s)ewfewew(){
afewfe(s,)wfew{
fef ewee{
a sefe few:has(few,few){
aafew:has(few,fewf,few){
span:is(p, b, a),da{
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end