# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(https?:\/\/)?(www\.)?//gm;t' <<< "https://www.google.com
http://www.google.co.in
www.google.com
www.google.co.in
google.com
google.co.in
http://google.co.in"