re = /^(https?:\/\/)?(www\.)?/m
str = 'https://www.google.com
http://www.google.co.in
www.google.com
www.google.co.in
google.com
google.co.in
http://google.co.in'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result