package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?://)?(www\.)?`)
var str = `https://www.google.com
http://www.google.co.in
www.google.com
www.google.co.in
google.com
google.co.in
http://google.co.in`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}