$re = '@^(https?://)?(www\.)?@m';
$str = 'https://www.google.com
http://www.google.co.in
www.google.com
www.google.co.in
google.com
google.co.in
http://google.co.in';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;