use strict;
my $str = 'https://www.google.com
http://www.google.co.in
www.google.com
www.google.co.in
google.com
google.co.in
http://google.co.in';
my $regex = qr@^(https?://)?(www\.)?@mp;
my $subst = '';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";