#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(https?://)?(www\.)?"
Local $sString = "https://www.google.com" & @CRLF & _
"http://www.google.co.in" & @CRLF & _
"www.google.com" & @CRLF & _
"www.google.co.in" & @CRLF & _
"google.com" & @CRLF & _
"google.co.in" & @CRLF & _
"http://google.co.in"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)