import Foundation
let pattern = #"^(https?://)?(www\.)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.google.com
http://www.google.co.in
www.google.com
www.google.co.in
google.com
google.co.in
http://google.co.in
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)