# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.{13,}?[ ]/$0\n/g;t' <<< "This is a test. The app should break this string in substring on whitespaces after 13 characters"